Your service is not supported by my web browser

Don’t you love to see messages like this:

Or this:

The first example is from a webcast that I am scheduled to attend in 10 minutes. The second example is from a business database that we subscribe to. I just wonder when companies are going to get with the program and start to realize that it’s not that my browser is incompatible with their site or service. Rather, their site or service needs to make the “necessary adjustments” so that their service won’t be limited by my browser. As a Firefox user, I only use Internet Explorer in order to use two business databases, and apparently now, to attend this webcast. I should not be forced to use that browser for those purposes. Having to use IE in this way is sort of silly. It’s almost like taking your own silverware to a restaurant, just in case the restaurant isn’t modern enough to use silverware. And really, who uses Netscape??

3 thoughts on “Your service is not supported by my web browser”

  1. Yeah, I have the IE Tab add-on to FireFox just for such situations. NetFlix WatchNow (streaming video) requires IE, too.

  2. Actually there *are* some people using Netscape but that’s besides the points as far as I am concerned. Most of the time my old computer is perfectly adequate for my needs but just now and then I want to use the latest technology so “steal” time on my husband’s computer — no cookies allowed! Not ever! Not for any reason! So some things I simply have to miss out on.

  3. Have you tried the FireFox user agent plugin?
    https://addons.mozilla.org/en-US/firefox/addon/59

    It’s helped me out on a few of those sites with stupid browser detect scripts.

    Also, what ignorant webmasters (like the one who’s responsible for your second example) don’t realize… the newer Netscapes (7+) are built on the same rendering engine as FireFox. Why they don’t check/test for the second most popular browser (FireFox) and do for the minuscule market share of Netscape is beyond me.

Comments are closed.